Danbooru

Read the rules before proceeding!

Topic: DanbooruUp, tag completion for Firefox, Chrome, Opera

Posted under General

DakuTree

dean_exia said:
Got a problem here.

After clearing tags, the update showed the following result:
Could not get tags. Status 0.
Does the update not work after clearing tags or history?

Running Google Chrome 17.0.963.56 m

Had same problem, seems to be an issue with http://danbooru.donmai.us/tag/index.json?limit=0 not loaded.
I'm assuming this is also an issue with other browsers too.

So here's a quick fix for now :)

  • 1. Go to "C:\Users\%USERNAME%\AppData\Local\Google\Chrome\User Data\Default\Extensions\mmhjfbfpeoajkihjplllegaeefipdipg\0.4.0_0"
  • 1.a. If you're on a different OS, see http://www.chromium.org/user-experience/user-data-directory for directory.
  • 2. Open up background.js and either:
  • 2.a. Find line 135, and modify "/tag/index.json?limit=0" into "/tag/index.json?limit=175000"
  • 2.b. Replace the entire contents with this http://pastebin.com/raw.php?i=UQt1c8D9
  • 3. Reload your browser and it should work again :D

If you're lazy, here's a simple click and install:

(This installs another copy of the ext, so make sure to disable the previous one, aswell as restart the browser)

Edit: From the looks of the code, the issue shouldn't happen with FF due to it not using the JSON api.

Updated by DakuTree

  • ID: 74447
  • Permalink
  • Apollyon

    Bumping this for an odd issue I'm having with Danbooru Uploader. On the Upload to Danbooru dialog, the Tag Autocomplete doesn't seem to place the cursor after the space when the tag is entered anymore. Yet the space after the tag is being created. However, the Tag Autocomplete is working as intended on Danbooru and other compatible sites (properly adding the space after hitting enter/clicking a tag).

    I recall this starting to happen around the moment I updated Firefox to version 12.0, so I assume that might be partly responsible for this. Sounds like a trivial issue, but it's annoying having to hit the spacebar manually to separate tags now.

  • ID: 76818
  • Permalink
  • v571866

    same issue with Apollyon here.

    Requesting update.

    -z905844

  • ID: 76819
  • Permalink
  • Shinjidude

    I rarely use Danboorup to upload directly anymore (use it mostly for the autocomplete in-browser), but I noticed the same issue. It's slightly annoying now to have to deal with and compensate for two different behaviors. Of the two, the automatic space is quite preferable.

  • ID: 76820
  • Permalink
  • Kadoya

    I'm with Apollyon's Firefox theory. The laptop that I noticed the space issue had Firefox 12.0. The old machine I'm using now (the laptop mentioned first died on me though I can get a refund) has 11.0.

  • ID: 76852
  • Permalink
  • DakuTree

    Here's a temporary solution: Download
    Simply fixed by changing the space to a double space, this moves along the pointer so you don't need to do it manually.
    It does add an extra space, but that isn't really much of a problem.

    Strangely enough, having a look at the code..I can't see a reason why this wouldn't work with FF12, must be some kind of bug.

  • ID: 76853
  • Permalink
  • Apollyon

    DakuTree said:
    Here's a temporary solution: Download
    Simply fixed by changing the space to a double space, this moves along the pointer so you don't need to do it manually.

    This will do just fine. Thanks!

  • ID: 76855
  • Permalink
  • user 356931

    I've been getting md5 mismatch consistently recently (hence the image not uploading) using this when trying to upload images that have just been posted to pixiv. Using firefox 14.0.1. Bug or not?

    Updated by user 356931

  • ID: 79142
  • Permalink
  • Schrobby

    Skingraft said:
    I've been getting md5 mismatch consistently recently (hence the image not uploading) using this when trying to upload images that have just been posted to pixiv. Using firefox 14.0.1. Bug or not?

    I use FF14.0.1 as well without that problem. It might be a conflict with some other AddOn you're using.

  • ID: 79143
  • Permalink
  • DakuTree

    Here is something people may find extremely useful..
    I've implemented user-set aliases into DanbooruUp.

    This allows you to add already existing aliases that aren't normally in the DB, aswell as your own custom aliases (For example, '1g0' -> '1girl solo').
    You can also do some more useful things, like tag sets for characters.
    Like 'patchk0' -> 'patchouli_knowledge touhou purple_hair purple_eyes long_hair' for example.

    Add aliases using the 'Add Alias' button in the DanbooruUp menu, and use the format it says to use in the pop-up box.
    This *may* run slower than the original script, as the database is about twice the size, and the autocomplete grabs twice as much info.

    Sadly this is only for chrome and opera.
    The differences between those versions and the firefox version is quite large, and I am honestly clueless on how to add this to the firefox ver.
    If someone wants to port the changes to FF, feel free. :)

    Download: Chrome | Opera (You'll have to drag the file to your browser for it to install, github is a bit picky.)
    Readme (Might be worth having a look at this)
    If you're curious about the changes, they are more or less the same in both scripts. Chrome Changes | Opera Changes

    Known issues:
    Although it shouldn't, it may port over the old DanbooruUp database, click the "Fix DB" button on the DanbooruUp menu to fix this.
    Aliases cannot be changed/removed after being added without using some kind of SQLite DB editor. So be careful when making aliases.

  • ID: 79894
  • Permalink
  • Mysterio006

    Hm, I keep getting "1g" by accident, so this might help... But unfortunately I'm a FireFox user. Thanks for the updates, though.

  • ID: 79896
  • Permalink
  • v571866

    thanks for the update, even if there is still no firefox version- eagerly waiting for it.

    and there is still an issue with uploading files above 10200KB (10MB) though, so probably bumping the relevant thread for this.

  • ID: 79924
  • Permalink
  • DakuTree

    z905844 said:
    and there is still an issue with uploading files above 10200KB (10MB) though, so probably bumping the relevant thread for this.

    That's an issue with Danbooru, not DanbooruUp.
    For whatever reason, file uploads are restricted to 10MB.
    Use some kind of external file host so you can use that as a source (Dropbox for example).

    Saying that though, if it's a scan and it's over 10MB, it might be better to just reconvert it to JPG at 96-99 quality.

  • ID: 79925
  • Permalink
  • v571866

    bumping

    I am now getting an "access denied (are you logged in properly?)" error.

    does anyone have this problem?

    currenly only having this problem on yande.re but i have not been able to test it on other sources.

    Update: attempting to upload from nicoseiga also results in this error.

    I have been properly signed in.

    Update: attempting to upload on all sites will now result in the error.

    Updated by v571866

  • ID: 82970
  • Permalink
  • dovac

    z905844 said:
    currenly only having this problem on yande.re but i have not been able to test it on other sources.

    We moved our backend to jruby, not sure if that would cause problems.

  • ID: 83012
  • Permalink
  • v571866

    problem is now resolved.

    uploads can now happen normally again.

  • ID: 83022
  • Permalink
  • fireattack

    So it doesn't work well with new danbooru?

    In the "upload to danbooru" window, "find artist" doesn't work. Under after finishing any uploads, it shows an error.

  • ID: 84758
  • Permalink
  • Sal.N

    fireattack said:

    So it doesn't work well with new danbooru?

    In the "upload to danbooru" window, "find artist" doesn't work. Under after finishing any uploads, it shows an error.

    Find artist aside, but you can still use it. The image will be uploaded normally despite showing error.

    Updated by Sal.N

  • ID: 84769
  • Permalink