Danbooru

Read the rules before proceeding!

Topic: DanbooruUp, tag completion for Firefox, Chrome, Opera

Posted under General

Miragu

zatchii said:

It doesn't appear at all? Which browser are you using? Do you see a drop-down when you start typing in the search field?

When searching on danbooru, it doesn't appear.
When editing a post (box below pic) it doesn't appear.
When I right click a picture, "upload to danbooru", it works, only on the small window I upload with.
When I upload normally, it's the same as editing a post.

I use Firefox Aurora (the beta beta of Firefox), version 22.0a2. Windows 7 x64

  • ID: 87687
  • Permalink
  • Kenaya

    Miragu said:

    When searching on danbooru, it doesn't appear.
    When editing a post (box below pic) it doesn't appear.
    When I right click a picture, "upload to danbooru", it works, only on the small window I upload with.
    When I upload normally, it's the same as editing a post.

    Same. Nightly 23.0a1 (20130429030926), Win8 x64.
    Error from console: http://pastebin.com/HZPyvTxw
    I think that developers somehow changed sandbox function O_o

  • ID: 87899
  • Permalink
  • zatchii

    Thanks for the reports. 0.5.1 is out, with some bug fixes.

    • Should work in Firefox 22 and 23 now
    • Search on right click goes to tag search again
    • Should work in slightly older versions of Chrome
    • Notes no longer appear above the settings box
    • Enable completion on sonohara and hijiribe in Chrome and Opera
    • Fixed drop-down placement in Opera
  • ID: 87928
  • Permalink
  • Miragu

    zatchii said:

    Thanks for the reports. 0.5.1 is out, with some bug fixes.

    • Should work in Firefox 22 and 23 now
    • Search on right click goes to tag search again
    • Should work in slightly older versions of Chrome
    • Notes no longer appear above the settings box
    • Enable completion on sonohara and hijiribe in Chrome and Opera
    • Fixed drop-down placement in Opera

    Wooooooooooooooooooooooooooooooooooooo!

    That said, I think you forgot to update the download link at http://pianosite.net/danbooruup/

    'cause I just reinstalled 0.5.0 with the firefox extension link

  • ID: 87935
  • Permalink
  • Kikimaru

    The "Upload to Danbooru" option from right-click has disappeared in 0.5.1 (Chrome)

  • ID: 87943
  • Permalink
  • zatchii

    Kikimaru said:

    The "Upload to Danbooru" option from right-click has disappeared in 0.5.1 (Chrome)

    I'll fix this when I find out how, but for now, one workaround is to remove and reinstall the extension.

  • ID: 87978
  • Permalink
  • Miragu

    So yeah, zatchii. I'm REALLY enjoying being able to tag without typing things out letter by letter again now.

    If I have any suggestions for future improvement though, and I don't know if this has been suggested before but, if there was a button on the menu I get from Right Click> Upload to Danbooru that just lets me check if the picture I right clicked has been uploaded to Danbooru before, that would help speed up uploading so much, and prevent duplicates. It would be like similar images check in Danbooru, but with your tool.

  • ID: 87998
  • Permalink
  • Kikimaru

    Decided to switch from Chrome to Firefox.

    Uh... how do I get this extension to upload?
    I get a little pop-up box when I do "Upload to Danbooru" which lets me enter a bunch of tags, but it gives me a "403 Forbidden" error when I try to submit.

  • ID: 88176
  • Permalink
  • Sal.N

    Kikimaru said:

    Decided to switch from Chrome to Firefox.

    Uh... how do I get this extension to upload?
    I get a little pop-up box when I do "Upload to Danbooru" which lets me enter a bunch of tags, but it gives me a "403 Forbidden" error when I try to submit.

    That's because you aren't logged in danbooru.donmai.us. Logging in other server such as hijiribe alone won't work.

    Another method is going to the extension's Options -> Danbooru Sites -> add in http://hijiribe.donmai.us/uploads.xml and choose this URL when uploading.

    Updated by Sal.N

  • ID: 88177
  • Permalink
  • Kikimaru

    Sal.N said:

    That's because you aren't logged in danbooru.donmai.us. Logging in other server such as hijiribe alone won't work.

    Another method is going to the extension's Options -> Danbooru Sites -> add in http://hijiribe.donmai.us/uploads.xml and choose this URL when uploading.

    I *only* ever log into Danbooru.donmai.us

    Adding http://hijiribe.donmai.us/uploads.xml to Danbooru Sites did not fix.

    New issue:
    Trying to update the Tag List with default URL (http://danbooru.donmai.us/tags.json) just gives me an infinite http_error 403 loop, which can only be exited by restarting FF.

    Using FF20 on Mac.

  • ID: 88178
  • Permalink
  • Sal.N

    Kikimaru said:

    I *only* ever log into Danbooru.donmai.us

    Then I have no idea why. I can both upload and update Tag List normally, FF21.

  • ID: 88184
  • Permalink
  • Toks

    You could have canceled by pressing the escape key. But I agree that there needs to be a working button for it.

    I managed to get it working by first clearing the entire tag history ("Clear tags"), and then updating. (And /cache/tags.json is the only address that will work.)

  • ID: 88490
  • Permalink
  • v571866

    Toks said:

    You could have canceled by pressing the escape key. But I agree that there needs to be a working button for it.

    I managed to get it working by first clearing the entire tag history ("Clear tags"), and then updating. (And /cache/tags.json is the only address that will work.)

    it now worked.

    thanks.

  • ID: 88571
  • Permalink
  • ilpalazzo-sama

    (bug report)

    0.5.1, Firefox 21.0, Arch Linux and Windows 7 (both AMD64).

    Typing “_” as last character messes with the drop-down auto-completion.
    For instance, typing “bed” suggests (bed, bed_sheet, bedroom, and so on), “bed_” suggests nothing, “bed_s” suggests (bed_sheet, bed_straps).
    When typing a character after the “_” and removing it, the suggestions are correct. (bed_sheet, bed_frame, and so on)
    When typing “bed”, going in another tab, going back, typing “_”, the suggestions are correct. (bed_sheet, bed_frame, and so on)

    New user, haven't read anything but OP post and last page, so “It's not a bug, it's a feature” and “Won't” fix are acceptable answers.

    Thanks for the good work, btw. I'm tagging actively on Danbooru since yesterday, using your extension since this morning, and it's already helping me a lot.

    Updated by ilpalazzo-sama

  • ID: 88730
  • Permalink
  • Kadoya

    Is it just me or is tag auto-complete not working for me (aside from using DanbooruUp to upload) here and Sonohara (Hijiribe is working though).

  • ID: 88798
  • Permalink
  • Kikimaru

    Yeah stopped working on Danbooru for me too.
    *edit*
    Working again on post upload page, but not main page.

    *edit edit*

    Nope, stopped working again.

    Updated by Kikimaru

  • ID: 88811
  • Permalink
  • Kikimaru

    On further inspection, it's seems to be because DanbooruUp can't work with HTTPS connections, and FF21 auto-completes to HTTPS.

  • ID: 88894
  • Permalink